Skip to content   CVS Version Control  |  Other Software  |  All Downloads  |  Buy Online  |  Support  |   Documentation Library    
Skip to content
Skip to content   Skip to content
 
Last Modified: Friday, November 14, 2014 Home > Other Software > Change Management > CVS Suite 2009R2 

CVS for Windows ( also OS/400 Mac OS X Linux )    Español  Deutsch  日本

CVS Suite is a modern versioning system that combines the power and stability of CVS with modern easy to use client software and support for Configuration Management best practice.

As the newest major release of the world’s most popular versioning system, CVS Suite 2009R2 continues CVSNT’s blazing pace of innovation with new features and usability enhacements.

What’s Included

Documentation

  • The CVSNT Admin and User guide All About CVS: Design and Build an Effective Configuration Management Solution using CVS Suite
    (requires Adobe Acrobat PDF reader)
  • Reference Guide
    (Requires Microsoft HTML Help reader)

CM Server

  • CM Server 2008 for Windows Server 2003 32 or 64 bit with SQL Server 2005
  • CM Suite 2008 includes CVS Suite 2009R2

CVS Suite Server x32

  • CVS Suite 2009R2 Server for Mac OS X, Windows XP SBS/Pro/x64, Windows Vista Pro/x64, Windows 7 Pro/x64, , Windows 2003/2008/2008R2 x32/x64, Red Hat Linux ES v4/v5 (32 bit)
  • CVS Suite 2009R2 Server Audit Integration for Mac OS X, Windows XP/Vista/7 Pro/x64, Windows 2003/2008/2008R2 x32/x64, Red Hat Linux ES v4/v5 (32 bit)
  • CVS Suite 2009R2 Server Build Integration for Mac OS X, Windows XP/Vista/7 Pro/x64, Windows 2003/2008/2008R2 x32/x64, Red Hat Linux ES v4/v5 (32 bit)
  • CVS Suite 2009R2 Server Bugzilla 2.18 Integration for Mac OS X, Windows XP/Vista/7 Pro/x64, Windows 2003/2008/2008R2 x32/x64, Red Hat Linux ES v4/v5 (32 bit)
  • CVS Suite 2009R2 Command Line Client for Mac OS X, Windows XP/Vista/7 Pro/x64, Windows 2003/2008/2008R2 x32/x64, Red Hat Linux ES/WS v4/v5 (32 bit)
  • Unison 2.13.16 Repository Replication Integration for Mac OS X, Windows XP/Vista/7 Pro/x64, Windows 2003/2008/2008R2 x32/x64, Red Hat Linux ES v4/v5 (32 bit)
  • If Windows 2003 Server Standard/Enterprise/Datacenter, Windows Server 2008 or Windows Server 2008R2 are used we recommend a Support Level.

CVS Suite Server x64

  • CVS Suite 2009R2 for SuSe Enterprise Linux 64 bit
  • CVS Suite 2008 for HPUX 11i PA-Risc
  • CVS Suite 2008 for HPUX 11i Itanium/Integrity
  • CVS Suite 2008 for Solaris 9/10 Sparc
  • CVS Suite 2009R2 Command Line Client for SuSe Enterprise Linux 64 bit
  • CVS Suite 2008 Command Line Client for HPUX 11i PA-Risc, HPUX 11i Itanium/Integrity, Solaris 9/10 Sparc
  • CVS Suite 2009R2 x32 including Windows 2003 Server and Windows 2008 Server
  • CVS Suite 2009R2 x32 Command Line Client for Mac OS X, Windows XP/Vista/7 Pro/x64, Windows 2003/2008/2008R2 x32/x64, Red Hat Linux ES/WS v4/v5 (32 bit)

CVS Suite Server MultiSite

  • Multi Site repository replication requires:
    • CVS Suite Server 2009R2 or CVS Suite Server x64, plus
    • Silver Support or higher, plus
    • on site installation and consulting.

CVS Suite Windows Client

  • Tortoise CVS for Windows XP Home/Pro/x64, Vista Home/Pro/x64, Windows 7 Pro/x64
  • WinCVS CVS for Windows XP Home/Pro/x64, Vista Home/Pro/x64, Windows 7 Pro/x64
  • WinMerge for Windows XP Home/Pro/x64, Vista Home/Pro/x64, Windows 7 Pro/x64
  • Release Manager 2008 for Windows XP Home/Pro/x64, Vista Home/Pro/x64, Windows 7 Pro/x64
  • Suite Studio 2008 for Windows XP Home/Pro, Vista Home/Pro/x64, Windows 7 Pro/x64
  • CVSNT SCCI 2008 Visual Studio 6/.NET 2005/2008 running on Windows XP Home/Pro/x64, Vista Home/Pro/x64, Windows 7 Pro/x64. (Express editions of Visual Studio may not support this feature, eg: Visual Studio Express 2012)
  • If CVSNT for Windows 2003 Terminal Services Standard Server/Enterprise/Datacenter, Windows Server 2008 or Windows Server 2008R2 are used please choose a Silver or higher support.

Other Software

  • Mac CVS X for OS X 10.3.7 to 10.6.x (not supported on 10.7)

Specifications:

Languages:

  • English

Hardware Requirements for CVSNT/CVS Suite Server

  • PC Processor: Pentium III or higher. (AMD K6 is not supported)
  • Mac OS X Processor: G4 800Mhz or higher.
  • Sun Processor: Sparc
  • HP Processor: PA-Risc or Itanium/Integrity
  • Minimum RAM is typically 128Mb over Operating System requirements plus 12MB per simultaneous user. Triple this if using binary deltas. The physical memory should be at least triple the size of the largest file to be committed or checked in.
  • Minimum available Disk Space: 5GB (disk must be local to CVS Suite server). Recommend SCSI with RAID (battery backed write cache) or SAN (iSCSI or Fibre)
  • Additional detail is available in the eBook 'All About CVS' in the section titled 'Designing a solution' under the heading 'Server Architecture'.

Hardware Requirements for Change Manager/CM Server

  • PC Processor: Pentium IV or higher. (Xeon recommended)
  • Minimum RAM is typically 384Mb over Operating System and Database Server requirements plus 12MB per simultaneous user. Triple this if using binary deltas. The physical memory should be at least triple the size of the largest file to be committed or checked in.

Hardware Requirements for CVSNT/CVS Suite Clients

  • PC Processor: Pentium III or higher. (AMD K6 is not supported)
  • Mac OS X Processor: G4 500Mhz or higher.
  • Minimum RAM is typically 64Mb over Operating System requirements. Some operations may require additional memory.

Software Requirements for Change Manager/CM Server

  • Operating System:
    • Windows Server 2003 recommended.
    • Support for other operating systems depends on customer demand, contact sales for a quote
  • Database Server:
    • Microsoft SQL Server 2005 recommended.
    • Support for other databases depends on customer demand, contact sales for a quote
  • Software required to read documentation:
    • Adobe Acrobat Version 7.0 or higher

Software Requirements for CVSNT/CVS Suite Server

  • Operating System x32:
    • Windows Server 2003, 2008 or 2008 R2 or x64 recommended. Windows XP Pro/x64, Vista Pro/Business/x64, Windows 7 Pro/Ultimate/x64. Windows 2000 Pro/Server (Suite 2008 only), or
    • Mac OS X 10.4.2(tiger)/10.5(leopard)/10.6(snow leopard) recommended. 10.4 (tiger) or higher. 10.3.7 or higher with Suite 2008 only
    • Red Hat ES Linux v4 Update 1 or later (including v5)
  • Operating System x64 (CVS Suite x64 only):
    • HPUX 11i Version 1 or higher (PA-Risc), or
    • HPUX 11i Version 2 or higher (Itanium/Integrity), or
    • Solaris 9 or Solaris 10 (Sparc), or
    • SuSE Enterprise Linux v9 or later, or
    • Windows Server 2003, 2008 x32 or x64 or 2008 R2 x32 or x64 (CVS Suite Server x32) recommended. Windows XP Pro/x64, Vista Pro/Business/x64, Windows 7 Pro/Ultimate/x64, or
    • Mac OS X Server 10.4(tiger)/10.5(leopard)/10.6(snow leopard) recommended (CVS Suite Server x32), or
    • Red Hat ES Linux v4 Update 1 or later (CVS Suite Server x32)
  • Optional Software required for some plugins (e.g.: Bugzilla and Audit Integration):
    • Perl 5.6.1
    • MySQL Server 4.1
    • Bugzilla/MySQL 2.18, 2.20, 2.22 or 3.0; Mantis/MySQL (version TBA); Jira/MySQL (3.12.2)
  • Software required to read documentation:
    • Adobe Acrobat Version 7.0 or higher
    • Microsoft HTML Help viewer (included with windows)
  • CVSNT Server is incompatible with and must not be installed on a machine with:
    • Windows: Cygwin CVS
    • Unix/Linux: CVS 1.11, 1.12 (if parallel run is required please choose Silver or higher Support)
    • Virus scanner which scans CVSNT temp or repository directories
    • CruiseControl CVS plugin (use the supplied CVSNT Build Integration)
    • Nod32 Anti Virus (in particular the IMON service)
    • Aventail AutoSocks

Software Requirements for CVSNT/CVS Suite Client

  • Windows 7 Pro or x64, Windows Vista Pro or XP Pro recommended. Windows XP Home and Windows 7 also supported. Windows NT 4 SP6 supported on Suite 2008 only
  • Software required to read documentation:
    • Adobe Acrobat Version 5.0 or higher
    • Microsoft HTML Help viewer (included with windows)
  • CVS Suite/CVSNT Client is incompatible with and must not be installed on a machine with:
    • Windows: Cygwin CVS
    • Unix/Linux: CVS 1.11, 1.12 (if parallel run is required please choose Silver or higher Support)
    • Virus scanner should not scan CVSNT temp directories
    • Nod32 Anti Virus (in particular the IMON service)
    • Aventail AutoSocks

Other Limitations

  • Repositories on network drives, network shares or on a SAN connected by TCP/IP are not supported.
  • Repository must be stored on a local drive to the server and not be scanned by a virus scanner.
  • Checkout directory must be stored on a local drive to the workstation (if checkouts to network drives are required please choose Silver or higher Support.
  • A server can only host one version of CVS or CVSNT Server (if you require multiple server versions on a single host please choose Silver or higher Support.